Tutorial: Advanced texture editing


Sometimes there are artefacts in the textures that are generated by the automatic texturing process. This is due to limitations in the accuracy of the geometry and camera registration errors. The automatically generated textures will generally not have noticeable seams but sometimes structured features such as lines and text can be broken up and require further manual correction.


A powerful suite of texture editing tools is provided that allow users to eliminate most texturing artefacts. These tools allow image data from a single photograph in your project to be used to replace the texture for a problematic region on the object. In this example, we will show how this can be achieved using the "Layers" capability of standard image editing tools such as PaintShop Pro and PhotoShop.

Starting Point

Create a textured 3D model from a set of photographs. Identify any problematic regions where the texture could be improved using one of the original photographs.

Figure 1. 3D model with artefact circled in red
Step 1

Find a good view of the problem area from the photographs in your project. This should ideally be close to a "front-on" view of the region that needs touching up. Double-click the thumbnail to check the right image has been found.

Quick Fix for Textures

A simple alternative to using a 3rd party image editor for correcting artefacts is provided. Instead of selecting a specific region in a chosen photo you can use the whole photograph. Simply ctrl-drag the thumbnail image into the 3D view (i.e. drag with the left mouse button down whilst holding the control key) and the textures will be updated. Some feathering will be applied to try to avoid noticeable seams. This mechanism does not give you the fine control you get using an external 2D image editor but can be useful for quickly fixing up problem regions. You can even ctrl-drag a thumbnail onto an untextured model!

Step 2

We need to transfer the photo into a 2D image editor application. This is best achieved using the clipboard so that a colour-corrected downsampled image is used where appropriate. To do this right-click with the mouse over the required thumbnail and select Images > Copy Image menu item.

Paste the clipboard image as a new image into your 2D image editor application. Take care that the image is not resized (see Editing the textures).

Step 3

Change the viewpoint of the 3D model to match the chosen photo. Simply drag the chosen thumbnail image into the 3D view and the correct viewpoint will automatically be displayed.

Now copy this view of the textured model onto the clipboard using the ID_MODEL_COPYVIEW.jpg Copy View button.

Step 4

Since the viewpoint was chosen to match the selected photo, the clipboard image and the image in our 2D image editor should be correctly aligned. We can now return to the 2D image editor and paste the clipboard image as an extra "Layer" on top of the existing image.

In PhotoShop simply select the "Paste" option from the "Edit" menu. In PaintShop Pro select the "Paste" option from the "Edit" menu and click on "As New Layer".

Figure 2. Base layer contains original image
Figure 3. Next layer contains rendered view
Step 5

To replace the problem region we will create a mask for the new layer and "burn" out the problem area to reveal the original image data.

Create an opaque mask for the layer. In PhotoShop select "Add Layer Mask" from the "Layer" menu and click "Reveal All". In PaintShop Pro select "New" from the "Masks" menu and click "Show All".

Step 6

By carefully editing the mask we can etch away the problem areas to reveal the pixels from the original photograph. A soft brush is recommended to ensure there are no obvious seams. In this way you can control the exact proportion of the original and texture blended images to use.


To edit the mask in PhotoShop select a dark or black foreground color using the slider in the "Color" toolbar. Select the "Paintbrush" tool and choose a suitably sized soft brush. Then start painting over the problem areas with the mouse until you are happy.

To edit the mask in PaintShop Pro, select the "Edit" option from the "Mask" menu. Then select a dark or black foreground color and click on the "Paint Brush" tool in the main toolbar. From the tool options select the desired brush size and a low value for "hardness". Now start painting over the problem areas until you are happy.

Step 7
Figure 4. Edited layer mask

The edited image can now be transferred back via the clipboard or "drag and drop". First the image needs to be a flattened to a single layer. In PaintShopPro the flattened image can then be copied on to the clipboard and pasted into 3DSOM Pro using ID_MODEL_PASTEVIEW.jpgPaste View button. In PhotoShop select the "Move Tool" and drag the flattened image into the View Model Window in 3DSOM Pro

Figure 5. Edited model in 3DSOM Pro