3.2. Reference: The main menu

File menu

The File > New menu item closes the current project and start a new one, prompting you to select the images to use for the new project. You can select more than one image using the Ctrl key and clicking on or dragging round the additional filenames. All the images should be in the same directory, but can be saved in different formats. You can always add more images later from the Images > Add Images... menu item.

The File > Open... menu item closes the current project and open a previously saved project. 3DSOM Pro will try to find the images used in the project from the folder they were in when you last saved the project. If they are not there, it will look in the same directory as the project file in case you have moved the project around. If they still can't be found you will be prompted to locate the images.

The File > Close menu item closes the current project. You will be prompted to save the project first if you have made unsaved changes.

The File > Save menu item saves the current state of the project. If you haven't already saved the project, you will be prompted for a filename. Note that the undo information is not saved with the project and neither are the original images. Unless you do not wish to edit the project further, the original images should be kept in order to continue working with the project later.

The File > Save As... menu item saves the current state of the project as for File > Save menu item but under a different name.

The File > Page Setup... menu item allows you to decide how big to print the calibration target(s). You can either set the diameter of the mat or choose to fit it onto a chosen number of pages. When printing across multiple pages, you will need to stick the pages together accurately using the markings provided.

The File > Print Preview... menu item displays a preview of the calibration target(s) so you can see how it will print on your chosen printer.

The File > Print Mat... menu item is used to print out the calibration target(s). This will open a print dialog so you can choose the printer to use. You can change the size of the mat from the page setup dialog by choosing File > Page Setup... menu item first.

The File > Settings... menu item opens the 3DSOM Pro Settings Window where you can alter various settings associated with the application and current project. The current settings are saved when you close 3DSOM Pro and reloaded next time you start. Most settings are also saved with and loaded from the 3DSOM Project file.

The File > Export... menu item opens the Export Window for exporting the finished model. The Exporting the finished model section describes the options available.

The File > Import... menu item allows you to import geometry from a 3D Studio Max object file or from a STL file. This provides a means to texture external geometry.

The File > Exit menu item closes 3DSOM Pro prompting you to save any unsaved project first.

The Main Menu > File menu also contains a list of up to the four most recently opened files as a shortcut for opening these projects.

Edit menu

The Edit > Undo menu item returns either the current mask (when the Edit Masks Window is active) or the model (when the View Model Window is active) to its state before the previous operation. All operations on the mask can be undone as can any operation that modifies the model geometry or texture map. Note that operations on the images in the project such as changing their type or deleting them are not kept in the history.

The Edit > Redo menu item re-applies the last operation that has been undone straight after doing Edit Model > Undo Model Edit menu item, either to the currently loaded mask or the model depending on whether the Edit Masks Window or the View Model Window is active.

The Edit > Copy menu item (when the View Model Window is active and the texture map has been generated) copies the current view of the model onto the Windows clipboard ready for texture editing in an external application.

The Edit > Paste menu item (when the View Model Window is active) blends the image on the Windows clipboard back into the texture map. The image on the clipboard must be the same size as the other images in the project and should be an edited version of an image obtained using Texture Editing > Copy Texture menu item.

View menu

The View > View Image Thumbnails menu item switches the Thumbnail Window to displaying thumbnails for each image.

The View > View Image Details menu item switches the Thumbnail Window to a list displaying details for each image in columns.

The View > Edit Mask menu item activates the Edit Masks Window for viewing and editing masks, hiding the View Model Window.

The View > Edit Geometry menu item activates the View Model Window for viewing and editing the model, hiding the Edit Masks Window.

The View > Toolbar menu item toggles display of the main toolbar at the top of the 3DSOM Pro window.

The View > Edit Toolbar menu item toggles display of the Edit Masks toolbar associated with the Edit Masks Window and the View Model toolbar associated with the Edit Masks Window.

The View > Status Bar menu item toggles display of the main status bar at the bottom of the 3DSOM Pro window.

Processing menu

The Processing > Make All menu item can be used to build a complete model automatically. If you haven't started a new project already, it will create a new project, prompting you for images. It then proceeds to open and run the three main wizards, the Mask Wizard, the Surface Wizard and the Texture Wizard and then opens the Export Window ready for you to choose how to save your finished model. You can interrupt this process at any point by interacting with one of the wizards.

The Processing > Mask All Images... menu item opens the Mask Wizard to guide you through automatically creating masks for all the images. See the Masking the images section for more details.

The Processing > Generate Surface... menu item opens the Surface Wizard to guide you through creating the surface shape for the object and optimising the current surface. See the Building the wireframe model section for more details.

The Processing > Generate Texture Maps... menu item opens the Texture Wizard to guide you through generating a new texture for the model. See the Adding the surface texture section for more details.

The Processing > Generate Point Cloud menu item opens the Point Cloud Wizard to guide you through generating a point cloud from the images. Points are generated my matching image structure across pairs of images ("multi-stereo matching"). The resulting cloud can be used in the surface optimisation step. See the Generating a Point Cloud section for more details.

Images menu

This menu is described under The Thumbnail Window section.

Mask Tools menu, and Model Tools menu

These menus are described under The Edit Masks Window, The View Model Window sections respectively.

Help menu

The Help > User Guide.... menu item opens the help browser displaying the manual.

The Help > About 3DSOM Pro... menu item opens a dialog with information about the current version of the software and credits.