3.5. Reference: The View Model Window

This section describes the tools available for viewing and modifying with the 3D model displayed in the View Model Window. Please read the appropriate tutorials sections for an idea of why and when to use these tools and for tips on making the most of the tools available.

Figure 3.5.1. The View Model toolbar and View Model Window.

All the tools available from the View Model toolbar can also be accessed from the Main Menu > Model Tools menu except for the number of triangles slider. This menu can be accessed either from the main menubar when the View Model Window is active or by right-clicking in the View Model Window.

3.5.1. Viewpoint Tools

There are several tools for moving the model around in 3D to look at it from different viewpoints. These all operate using click and drag with the left mouse button.

With the ID_MODEL_ROTATE.jpgRotate (or Spin) model button selected, dragging the mouse rotates the object about its centre. Hold the CTRL key whilst dragging to spin the object around the centre of the window.

With the ID_MODEL_TRANSLATE.jpgMove model button selected, dragging the mouse moves the object left/right and up/down.

Dragging up and down the screen using the ID_MODEL_ZOOM.jpgZoom model button moves the object backwards and forwards, making it appear smaller or larger. The mouse wheel can also be used to do this.


Holding down Ctrl will temporarily swap between pairs of these tools, returning to the original tool when the key is released.

Clicking the ID_MODEL_RESET.jpgReset view button will return the camera to its default position. This has the whole object visible in the window and rotated to be viewed from the direction of the "tick mark" on the calibration target(s).

Clicking the ID_MODEL_LASTVIEW.jpgLast view button will return the viewpoint to the previous position.

Clicking the ID_MODEL_NEXTVIEW.jpgNext view button after Last view will move forward in the viewpoint history.

3.5.2. Display options

These options affect what is seen in the window, in particular how the model is drawn. Depending on what information has been generated for the model, not all these options will be available all the time.


It is sometimes helpful to remove the texture, for example, to help see the shape. You can also change the colours used for the window background and the wireframe from The 3DSOM Pro Settings Window.

The ID_MODEL_WIREFRAME.jpgView wireframe model button displays the model with lines around the edge of each triangle. This can be used to get a feel for how many triangles there are in the mesh and where they are dense or sparse.

The ID_MODEL_SOLID.jpgView flat shaded model button displays the model as a solid object but without texture. This is a good display mode to use when reducing the number of triangles in the mesh since you will see when the shape of the object starts to change.

The ID_MODEL_TEXTURED.jpgView textured model button displays the final model with a texture map generated from the images.

The ID_MODEL_VIEWDEPENDENT.jpgView Dependent Textures button this mode displays the model textured using the closest available source image. This is helpful for visualising how the textured model may appear before you have generated the texture map e.g. whilst you are still editing the geometry.

When the textured model is displayed, the ID_MODEL_USELIGHT.jpgUse Light Source button toggles a virtual light source. This is a useful preview if you are intending to export the model to a 3D editing package where you might relight it.


You can use keyboard shortcuts to swap between display modes: View wireframe model (F5), View flat shaded model (F6), View textured model (F7), and View Dependent Textures (F8).

The ID_SHOWPOINTS.jpgShow points only button displays the point cloud without the current surface mesh to allow you to examine the points more easily.

The ID_SHOWSURFACE.jpgShow surface only button displays the 3D surface mesh (solid, wireframe or textured depending on the current mode) without the point cloud to allow you to examine the 3D model more easily.

The ID_SHOWALL.jpgShow points and surface button displays both the 3D surface model with the point cloud overlayed.

The ID_MODEL_DISPLAYMAT.jpgToggle calibration mat button toggles the display of a virtual calibration mat. This can be useful to understand where the object's coordinate system is, particularly during and after alignment operations.

The Display Mode > Display Cameras menu item toggles the display of each of the camera positions for the images in the project. During alignment, the cameras currently being aligned are highlighted in red.


To identify the location of one particular camera, temporarily select it and open the Align Wizard to highlight it, but be careful to cancel the alignment operation afterwards.

3.5.3. Window Tools

During alignment operations, one of the images being aligned is displayed as a backdrop behind the model so that the model can be position to match this image. To help do this more accurately, there are some additional tools enabled only during alignment operations.

With the ID_MODEL_MAGNIFY.jpgMagnify View button selected, dragging the mouse up and down the screen zooms into or out of the current image allowing more or less detail to be seen. This differs from Zoom model which moves the camera closer to the object thereby altering the perspective — instead it keeps the object fixed relative to the background image.

With the ID_MODEL_PAN.jpgPan View button selected, dragging the mouse scrolls around the image, keeping the object fixed relative to the background image. Again this differs from Move model which would move the object relative to the background image.


Holding down Ctrl will temporarily swap between these two tools, returning to the original tool when the key is released.

Clicking on the ID_MODEL_RESETCAMERA.jpgFull Image button will reset the magnification so that the whole image fits in the window.

3.5.4. Triangles Control

The model is generated as a triangle mesh and a technique known as decimation is used to allow the number of triangles in the mesh to be varied interactively. As the number of triangles is reduced, the vertex that contributes least to the shape of the object is removed and the mesh reformed with one fewer triangles.

The number of triangles in the currently displayed mesh is shown in the View Model toolbar. Below it, there is a slider that can be used to interactively change the number of triangles. Alternatively, you can type directly into the number of triangles.

Note: If the slider is replaced with a Decimate button then you have probably cancelled the decimation process. Press this button to setup the decimation and display the slider again.

You can change the number of triangles even after the model has been textured, but it may be worth re-generating the textures once the final number of triangles has been chosen as the results may be different. See the section on Adjusting the decimation in Building the wireframe model for more details on choosing an appropriate number of triangles.

Note: If a subdivision surface has been generated then only three decimation levels are available as explained in the Improving the geometry with subdivision surfaces tutorial.

3.5.5. Geometry Editing Tools

The buttons in this group are used to modify the shape of the existing model and are therefore only enabled once some geometry has been created.

The ID_CREATE_MANUALVIEW.jpgCreate silhouette button will create a new image in the project from the current viewpoint, using the current geometry to define the mask for the image. This mask can then be edited and will modify the geometry next time the surface is generated. If the texture has been generated, you will be offered the chance to save a rendering of the model to an image file on disk associated with the new image.

When the ID_MODEL_MOVECLIP.jpgMove clip plane button is selected the clip plane is shown and dragging the mouse up and down moves the virtual clip plane up and down. Because images are usually taken from above the object, there is usually a slight 'doming' under the base of the object. Clipping is used to remove any parts of the model that are mistakenly included from the stand the object was placed on. To hide the clip plane, simply drag it down below the base of the model.

Clicking the ID_MODEL_CLIP.jpgClip model button causes all geometry below the current clip plane to be cut off. You can undo this operation by selecting Edit Model > Undo Model Edit menu item. See the section on Clipping away the stand in Building the wireframe model for more details.

The ID_DFILTERCLOUD.jpgFilter point cloud outliers button allows you to interactively filter out outlier points from the point cloud. A dialog will be displayed and by dragging the slider to the left you can eliminate more points and keep the more reliable 3D points.

Click the ID_OUTLINE_REGION.jpgDefine region to edit button to start interactively drawing a closed curve or polygon from the current 3D view. An additional toolbar of region-based editing tools will popup in the corner of the View Model Window. To start defining the region simply click in the View Model Window with the left mouse button. You can click points on the desired curve boundary and these will be smoothly interpolated (if the curve is too sharp a corner is created instead). You can hold down the left mouse button and drag to interactively place the next point. Hold down the CTRL key to create a sharp corner. Click on the first point to close the region. Once you have defined a closed region you can extrude, flatten, smooth, push or pull the surface as well as delete points in the point cloud within the extruded region.


When defining a region with the ID_OUTLINE_REGION.jpgDefine region to edit button, you can use the mouse-wheel to zoom-in or out as well as the ID_MODEL_MAGNIFY.jpgMagnify View button and the ID_MODEL_PAN.jpgPan View button.

The ID_ORTHOCAMERA.jpgOrthographic mode button toggles displaying the model with an orthographic projection instead of a perspective one. In orthographic mode extruded regions are prisms and a circular region would be extruded to a perfect cylinder rather than part of a cone.

3.5.6. Region based editing tools

The buttons in this group are displayed in a popup toolbar if you have selected the ID_OUTLINE_REGION.jpgDefine region to edit button. You should define a closed region before selecting any of the buttons.

Click the ID_PUSH_MODE.jpgPush-Pull mode button after defining a region to switch to push-pull 3D editing mode. In this mode you can interactively push or pull the surface within the defined region. First place an anchor point (displayed as a red sphere) on the surface by clicking with the left-mouse button (drag to adjust the point position). Then use the ID_PUSH_FORWARD.jpgPush Surface button or ID_PUSH_BACK.jpgPull Surface button to push the surface forward (into the screen) or pull the surface (out of the screen) — a green sphere is displayed where the selected anchor (red) point should end up. Hold down the buttons to push or pull the anchor point in larger increments. You can also use the viewpoint tools to examine the model from different directions as the model is updated. You can add more anchor points (if you changed viewpoint you will need to reselect push-pull editing mode), then use left and right arrows to select an anchor point and Delete to delete the point.

Click the ID_SMOOTH_REGION.jpgSmooth region button after defining a region to pop up an interactive slider that allows you to adjust the amount of smoothing to apply to the surface within the region. Check the preview box to see the result.

Click the ID_FLATTEN_REGION.jpgFlatten region button after defining a region to "flatten" on the model. Note that the boundary of the region remains fixed and the interior is modelled as a "membrane" similar to a film or soap bubble. So if the boundary of the region is flat the result will be a completely flat interior. Otherwise the effect is to "iron" out any bumps inside without changing the surface near the boundary.

The ID_CURVE_COOKIECUT.jpgExtrude selected shape button is used to extrude the boundary curve after you have defined a region boundary. The Extrusion Tool Window dialog will be displayed allowing you to interactively define the extent of the extrusion using a slider. You can click the "Preview" checkbox to see the result. By default the extruded region is removed from the model geometry (a Boolean subtract operation) — this is sometimes referred to as a "Cookie Cutter" tool. If you click the "Add Back" checkbox the extruded region is added to the current model (a Boolean union operation) and you can interactively define the other extent of the extrusion using the slider. The "Fit plane" checkbox creates an alternative extrusion that is perpendicular to a plane fitted to the surface at the region boundary.

The ID_DELETE_POINTS.jpgDelete points in region button is used to delete all the points in the point cloud within the extruded boundary curve after you have defined a region boundary.

After you defined a region you can click the ID_OUTLINE_DISCARD.jpg button to finish region editing operations and discard the defined boundary curve.

3.5.7. Texture Editing Tools

Once a texture map has been generated, it can be edited using an intuitive 2D interface by taking a copy of the rendered model from a particular viewpoint, modifying it in a separate image editing package, and then pasting it back into the model. The Editing the textures tutorial describes different ways in which this technique can be used.

Clicking the ID_MODEL_COPYVIEW.jpg Copy View button renders the model through a virtual camera from the current viewpoint and places it on the clipboard.

Clicking the ID_MODEL_PASTEVIEW.jpgPaste View button blends the image on the clipboard into the current texture map. The image must be the same dimensions as the other images in the project. You can undo this operation by selecting Edit Model > Undo Model Edit menu item.

With the ID_TEXTURE_FIX_MODE.jpgFix texture tool button selected, left-dragging on the model applies a special texture brush that can be used to quickly fix blemishes in the generated texture map. The closest image to the current viewpoint is used to interactively paint into the existing texture map. A soft brush is used to avoid any "seams". This is a fast alternative to modifying the textue map using the copy-paste mechanism.


Whilst the ID_TEXTURE_FIX_MODE.jpgFix texture tool button is selected hold down the CTRL key and left-drag to rotate the model and change the closest image used whilst painting.

Click the ID_TEXFIX_BRUSH.jpgTexture Fix Settings button to adjust the settings for the texture fix brush. For more details see Spot fixing the textures.

3.5.8. Measurement Tool

At the bottom of the View Model toolbar there is a ruler button you can click to enter "measurement mode" and take measurements on the model.

In "measurement mode" you can click and drag on the model to measure the distance between any two points on the model. A popup window displays the position of the start and end position in 3D space and the distance between them. You can change the displayed units using the drop-down menu. Close the popup measurement window to hide the info and switch to rotating the model.

Note: to get accurate measurement information you should make sure you enter the "Mat Scale" setting in the 3DSOM Pro Settings Window - see The 3DSOM Pro Settings Window. For imported models (OBJ, STL, 3DS) make sure the units in the file are mm (the default for models exported from 3DSOM Pro).


Hold the CTRL key while in "measurement mode" to temporarily switch to rotating the model as you drag. Select the ID_MODEL_ROTATE.jpgRotate (or Spin) model button to view the model and final measurement line from a different angle.

3.5.9. Material Maps

Once you have created a texture map you can also manually create additional maps to represent material propeties on a per-pixel basis. These additional "channels" are exported in the OBJ, WebGL and 3DSOM Pro Java formats to enhance the model appearance.

All the material channels functions are available from the Model Tools > Texture Channels menu.

Use the Texture Channels > Create New menu item to create (or replace) a new material channel. You can choose to create a specular or transparency channel which can be initially a single colour or based on the currently selected channel.

Use the Texture Channels > Delete Channel menu item to delete the currently selected material channel.

Use the Texture Channels > Invert channel menu item to replace the current material channel with the negative image of the existing map (black pixels become white and vica versa).

The Texture Channels > Standard (Diffuse) menu item, Texture Channels > Transparency menu item and Texture Channels > Specular menu item switch the current channel to the "Diffuse", "Transparency" or "Specular" maps. Once you have switched map you can manually edit using the Texture Editing tools.

For a more in-depth tutorial see Creating and Editing Material Maps.